炒股賺錢的入口:換手率成交量分析解盤公式源碼

換手率成交量分析解盤源碼如下:

{換手率成交量分析解盤}

VARIABLE:K=1;

VAR1:=SUM(VOL,0);

VAR2:=VAR1/CAPITAL;

N:=FLOOR(VAR2);

IF N=REF(N,1)+1 THEN BEGIN

STICKLINE(C,0,80,4,1);

DRAWTEXT(C,80,’ 第’),ALIGN0,COLORGREEN;

DRAWTEXT(C,70,’ ’+NUMTOSTR( N)),ALIGN0,COLORRED;

DRAWTEXT(C,60,’ 次’),ALIGN0,COLORGREEN;

DRAWTEXT(C,50,’ 完’),ALIGN0,COLORGREEN;

DRAWTEXT(C,40,’ 全’),ALIGN0,COLORGREEN;

DRAWTEXT(C,30,’ 換’),ALIGN0,COLORGREEN;

DRAWTEXT(C,20,’ 手’),ALIGN0,COLORGREEN;

DRAWTEXT(C,10,’ ’+NUMTOSTR( K)+’天’),ALIGN0,COLORGREEN;

K:=1;

END

ELSE

K:=K+1;

日換手:SUM(VOL,1)*100/CAPITAL,colorf0f000,LINETHICK0 ;

五日換手:SUM(VOL,5)*100/CAPITAL,colorf0f000,LINETHICK0 ;

十日換手:SUM(VOL,10)*100/CAPITAL,colorf0f000,LINETHICK0 ;

二十日換手:SUM(VOL,20)*100/CAPITAL,colorf0f000,LINETHICK0 ;

百日換手:SUM(VOL,100)*100/CAPITAL,colorf0f000,LINETHICK0 ;

AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

成交量(手):VOL,ColorC700FF,LINETHICK0;

主動買盤:IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLORred,

LINETHICK0;

主動賣盤:IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-AA*(HIGH-LOW),0-VOL/2)),color66ff00,

LINETHICK0;

{解盤:N=75 25 100 }

REFLINE: 0, 25, 75, 100;

Var1:=IF(MA(CLOSE,88),1,0);

Var2:=1/WINNER(CLOSE);

Var3:=100-ABS((CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100);

HSL:=vol/capital*100;

量能:=SUM(HSL,N);

漲幅1:=100*(CLOSE-REF(CLOSE,N))/REF(CLOSE,N);

流通市值:=capital*c;

AH:=HHV(流通市值,N);

AL:=LLV(流通市值,N);

t1:=if(HSL<=2,1,0);

t2:=if(HSL>2 AND HSL<3,1,0);

t3:=if(HSL>3 AND HSL<5,1,0);

t4:=if(HSL>5 AND HSL<8,1,0);

t5:=if(HSL>8 AND HSL<15,1,0);

t6:=if(HSL>15 AND HSL<25,1,0);

t7:=if(HSL>=25,1,0);

sss:=100/4;

i:=0;

IF  HSL<=2  THEN  BEGIN  DRAWTEXT(c>0 and DISPSTATUS=2,100-(sss*i),’日換手率在1%--2%,股價屬于成交低靡,屬于冷門股。日換手率成交小于3%的成交額稱為“成交無量”。’),Color00FFFF,ALIGN2; i:=i+1;

END

IF  HSL>2 AND HSL<3  THEN  BEGIN  DRAWTEXT(c>0 and

DISPSTATUS=2,100-(sss*i),’日換手率在2%--3%,股價屬于成交溫和,屬于備份股。’),Color00FFFF,ALIGN2;

i:=i+1;

END

IF  HSL>3 AND HSL<5  THEN  BEGIN  DRAWTEXT(c>0 and DISPSTATUS=2,100-(sss*i),’ 日換手率在3%--5%,股價屬于成交活躍,表示有莊家在積極活動,屬于熱門股。把10日平均換手率大于3%或大于5%,而后又縮量至換手率小于3%高度控盤的個股作為選股條件。’),Color00FFFF,ALIGN2; i:=i+1;  END

IF  HSL>5 AND HSL<8  THEN  BEGIN  DRAWTEXT(c>0 and DISPSTATUS=2,100-(sss*i),’ 日換手率在5%--8%, 大于7%,常常超過10%,屬于股價成交帶量,表明籌碼在急劇換手。發生在低位或是通過第一阻力區,很可能是強莊積極進貨。’),Color00FFFF,ALIGN2;

i:=i+1;  END

IF  HSL>8 AND HSL<15  THEN  BEGIN  DRAWTEXT(c>0 and DISPSTATUS=2,100-(sss*i),’ 日換手率大于8%--15%,股價屬于成交放量。’),ColorFFFFF5,ALIGN2; i:=i+1;  END

IF  HSL>15 AND HSL<25  THEN  BEGIN  DRAWTEXT(c>0 and DISPSTATUS=2,100-(sss*i),’ 日換手率大于15%--25%,股價屬于成交巨量,發生在高位或高位縮量橫盤之后,很可能是莊家出貨。’),Color00FFFF,ALIGN2;

i:=i+1;  END

IF  HSL>=25  THEN  BEGIN  DRAWTEXT(c>0 and DISPSTATUS=2,100-(sss*i),’ 日換手率大于25% 股價屬于成交怪異;周換手率大于25% 屬于成交活躍。’),ColorFFFFFF,ALIGN2; i:=i+1;  END

IF  量能>3*N AND 漲幅1>3*N  THEN  BEGIN  DRAWTEXT(c>0 and DISPSTATUS=2,100-(sss*i),’繼續大漲’),ColorFF00FF,ALIGN2; i:=i+1;  END

IF  量能<0.5*N AND 漲幅1<N  THEN  BEGIN  DRAWTEXT(c>0 and DISPSTATUS=2,100-(sss*i),’繼續小漲’),ColorFFFF00,ALIGN2; i:=i+1;  END

IF  量能<0.5*N AND 漲幅1>-N AND 漲幅1>0  THEN  BEGIN  DRAWTEXT(c>0 and DISPSTATUS=2,100-(sss*i),’繼續小跌’),ColorFFFF00,ALIGN2; i:=i+1;  END

IF  量能>3*N AND 漲幅1<-3*N  THEN  BEGIN  DRAWTEXT(c>0 and DISPSTATUS=2,100-(sss*i),’繼續大跌’),ColorFF00FF,ALIGN2; i:=i+1;  END

IF  ((量能>3*N AND 漲幅1<N) OR (量能<0.5*N AND 漲幅1>3*N)

OR (量能>3*N AND 漲幅1>-N AND 漲幅1<0) OR (量能<0.5*N AND 漲幅1<-3*N))  THEN  BEGIN  DRAWTEXT(c>0 and DISPSTATUS=2,100-(sss*i),’注意反轉:股價高位向下反轉,中位橫盤殺跌,低位向上反轉。’),ColorFFFFF5,ALIGN2;

i:=i+1;  END

IF  漲幅1>0 and 流通市值<=AL  THEN  BEGIN  DRAWTEXT(c>0 and DISPSTATUS=2,100-(sss*i),’流通市值減小,漲幅加大’),Color00FFFF,ALIGN2; i:=i+1;  END

IF  漲幅1<=0 and 流通市值<=AL  THEN  BEGIN  DRAWTEXT(c>0 and DISPSTATUS=2,100-(sss*i),’流通市值加大,漲幅減小’),Color00FFFF,ALIGN2; i:=i+1;  END;

DRAWTEXTREL(20 ,50 ,’趨勢看周線’ );

DRAWTEXTREL(20 ,200 ,’選股看日線’ );

DRAWTEXTREL(20 ,350 ,’買股看時線’ );

免責聲明:本文僅代表文章作者的個人觀點,與本站無關。其原創性、真實性以及文中陳述文字和內容未經本站證實,對本文以及其中全部或者部分內容文字的真實性、完整性和原創性本站不作任何保證或承諾,請讀者僅作參考,并自行核實相關內容。

http://image95.pinlue.com/image/34.jpg
分享
評論
首頁
安微11选五走势图 重庆快乐十分投注技巧 期货配资公司加盟 公安为什么不愿查网赌 广东快乐10分助手行不行 彩吧论坛首页一彩票论坛 北京快8开奖结果查询 幸运飞艇各种走势图 广东11选5开奖结果 基金配资多少倍 江西十一选五遗漏360网